Back to overview
Downtime

Admin Dashboard

Feb 21, 2026 at 05:36am UTC
Affected services
Protege App and Dashboard

Resolved
Feb 21, 2026 at 05:54am UTC

Services were restored

Created
Feb 21, 2026 at 05:36am UTC

The admin dashboard is impact by an outage that an upstream provider is having.