Back to overview
Degraded

Railway Network Outage

May 19, 2026 at 10:36pm UTC
Affected services
Extension Server for Office 365

Resolved
May 20, 2026 at 1:46am UTC

Everything has been resolved on Protege Review. We apologize for the inconvenience.

Updated
May 20, 2026 at 1:42am UTC

Services are now restored on Railway. Protege Review and all AI services are restored

Created
May 19, 2026 at 10:36pm UTC

The dashboard and AI services on Protege Review are down from our upstream cloud provider, Railway. The Network Outage is impacting several of our services.